Issue Discovered - Service disruption in All Regions – Mobile App (Android only)
Incident Report for xMatters
Resolved
The issue has been resolved, and no app update is required at this time.

We are continuing to investigate the root cause and develop permanent resolution to prevent this issue from reoccurring.
Posted Mar 21, 2024 - 16:12 PDT
Monitoring
The issue has been resolved; no app update is required.

The problem appears to have stemmed from a third-party conflict: the way the certificate transparency library handles updates from the Google log list conflicts with its own concurrency and job cancellation. We are continuing to monitor the situation and investigating ways to resolve the issue permanently.
Posted Mar 21, 2024 - 14:48 PDT
Update
We are continuing to work toward mitigation and resolution of this issue, and believe we have identified the root cause. We are currently developing and testing a potential fix. In the meantime, push notifications are still being delivered and customers have reported that allowing pages within the app to fully load and waiting before attempting to navigate away or perform another action has significantly reduced occurrences of the error.

We will continue to update as more information becomes available, but note that it will likely be necessary to update the app to resolve the problem.
Posted Mar 21, 2024 - 13:13 PDT
Identified
We've identified this issue as related to the Android certificate transparency library we use for enhanced security in xMatters. Certificate transparency is an important part of the mobile app's end-to-end security and we are currently testing mitigation strategies to ensure they will not cause any disruption of this feature.

We are continuing to investigate the issue and will provide more information as it becomes available.
Posted Mar 21, 2024 - 10:47 PDT
Investigating
We are investigating an issue with the Android mobile app not working on some Android devices. Reports indicate that users are receiving an error message that their devices cannot connect to xMatters We are currently investigating the issue and will update as information becomes available.

If you are also experiencing issues, or if you're not sure whether this issue impacts your service, please contact xMatters Support at https://support.xmatters.com/hc/en-us/requests/new - our support agents are waiting to help.
Posted Mar 21, 2024 - 09:30 PDT
This incident affected: Asia Pacific (Mobile App), Europe, Middle East, and Africa (Mobile App), and North America (Mobile App).