Issue Discovered - Service disruption in All Regions – Conferencing

Incident Report for xMatters

Postmortem

What happened? 

On October 20th, 2025, at approximately 1:21 AM Pacific, customers began reporting an issue affecting live call routing, conferences, and voice notifications. During this issue, customers in all regions would have been affected.

Why did it happen? 

This issue was caused by a global AWS outage that impacted one of our downstream providers, resulting in voice notifications, live call routing, and conferencing they were handling to fail. 

How did we respond? 

As soon as the first customer reported an issue, Customer Support engaged the Engineering teams and launched an investigation. Once they identified the root cause, the teams updated the primary provider for affected regions to an alternate provider that was not affected by the AWS outage. When the new provider was assigned, customers reported that all services were operating correctly. 

What are we doing to prevent it from happening again? 

While this issue was out of our control or that of our provider, we are working to identify potential ways to improve resilience in case of external factors such as this.

Posted Oct 29, 2025 - 14:54 PDT

Resolved

Our provider has confirmed the issue has been addressed, and all services have been restored. Thank you for your patience while we addressed this matter.
Posted Oct 21, 2025 - 09:34 PDT

Monitoring

Our downstream providers have deployed a fix and testing shows conferencing and voice systems are now working as expected. We are currently monitoring the situation to ensure the implementation is stable and that all services are restored.
Posted Oct 20, 2025 - 05:23 PDT

Identified

xMatters monitoring tools have identified a issue with xMatters Conferencing and Voice calls for clients in All Regions. The issue is due to downstream provider outages.
Posted Oct 20, 2025 - 03:20 PDT
This incident affected: Europe, Middle East, and Africa (Voice Notifications, Conferencing), Asia Pacific (Voice Notifications, Conferencing), and North America (Voice Notifications, Conferencing).