Issue Discovered - Service disruption in Europe Region – Web User Interface

Incident Report for xMatters

Postmortem

What happened? 

On May 1st, 2026, some customers reported an issue to xMatters Customer Support where attempting to send a message via the web user interface or viewing an alert on the Alerts report resulted in an error being displayed. The issue only affected the Reporting functions in the EMEA region; the system continued to accept signals, generate alerts, and send notifications across all regions. 

Why did it happen? 

The issue occurred when, during routine database maintenance, the database called a mismatched version of the library, resulting in an internal database error. The version mismatch within the cluster was traced to a prior database engine upgrade where a subset of replica nodes did not restart into the upgraded version. At no point was there any risk to data integrity. 

How did we respond? 

As soon as Customer Support confirmed the issue, they engaged the Engineering teams, who were able to identify the root cause and restore version consistency across all nodes. The teams validated stability and confirmed that all services were restored. 

What are we doing to prevent it from happening again? 

The Engineering Team has added explicit post-upgrade verification checks and monitoring to ensure node alignment is confirmed and maintained. This will provide safeguards to ensure node version alignment after upgrades and prevent this issue from reoccurring.

Posted May 12, 2026 - 13:32 PDT

Resolved

The issue has been addressed, and all services have been restored. Thank you for your patience while we addressed this matter.
Posted May 01, 2026 - 02:19 PDT

Monitoring

The xMatters Incident Response team has deployed a fix for the issue. We are currently monitoring the situation to ensure the implementation is stable and that all services are restored.
Posted May 01, 2026 - 02:03 PDT

Identified

The xMatters Incident Response team has identified the source of the issue and is working on a fix. We will update once a solution has been identified and implemented.
Posted May 01, 2026 - 02:01 PDT

Investigating

xMatters have identified a potential issue with the xMatters Web User Interface for some clients located in the Europe region. Accessing some pages including Alert details produces an error. We are currently investigating the issue and will update as information becomes available.

If you are also experiencing issues, or if you're not sure whether this issue impacts your service, please contact xMatters Client Assistance at https://support.xmatters.com/hc/en-us/requests/new - our support agents are waiting to help.
Posted May 01, 2026 - 01:45 PDT
This incident affected: Europe, Middle East, and Africa (Web Interface).