Issue Discovered - Service disruption in North American Region - Multiple Services

Incident Report for xMatters

Postmortem

What happened? 

On July 1st, 2026, some customers reported an issue to xMatters Customer Support where they were encountering authentication errors when accessing the web user interface. 

Why did it happen? 

This issue occurred because a database cluster reached 100% resource utilization, causing database requests to time out. An exceptional traffic pattern exposed a set of slow-running queries, which significantly increased query latency on the cluster. As latency increased, there was resource starvation and further degradation of the cluster's responsiveness, resulting in timeouts. 

How did we respond? 

As soon as Customer Support confirmed the issue, they engaged the Engineering teams to investigate. As designed, the system had restored itself before Engineering could implement any mitigation or recovery actions, but the teams were still able to identify and isolate the root cause. 

What are we doing to prevent it from happening again? 

To prevent this issue from reoccurring, the Engineering Team designed, developed, and tested a fix. They deployed the fix in the morning of Wednesday, July 8th, 2026, and it has been successfully implemented for all instances.

Posted Jul 09, 2026 - 12:21 PDT

Resolved

The issue has been addressed, and all services have been restored. Thank you for your patience while we addressed this matter.
Posted Jul 01, 2026 - 13:21 PDT

Monitoring

The xMatters Incident Response team has deployed a fix for the issue. We are currently monitoring the situation to ensure the implementation is stable and that all services are restored.
Posted Jul 01, 2026 - 13:07 PDT

Investigating

xMatters monitoring tools have identified an issue with xMatters On-Demand for some clients located in the North America region, limited to one database cluster. We are currently investigating the issue and will update as information becomes available.

If you are also experiencing issues, or if you're not sure whether this issue impacts your service, please contact xMatters Client Assistance at https://support.xmatters.com/hc/en-us/requests/new - our support agents are waiting to help.
Posted Jul 01, 2026 - 12:53 PDT
This incident affected: North America (Web Interface, Email Notifications, SMS Notifications, Voice Notifications, Conferencing, Integration Platform, API, Mobile App).